一念成妖選股公式

2021-12-01

一念成魔一念成佛全句

您好。
是魔是佛,皆唯自心,心動與靜,皆不可得。

求編寫一通達信公式

全部給你了,自己去參考一下,沒時間整理!
30個交易日內,股價跌幅達到一半的股票:
xg:(hhv(c,30)-c)/hhv(c,30)>0.5;
2,今天的量 是5天平均的 2倍以上
xg:v>ma(v,5)*2;
縮量
vol/ma(vol,10)<0.3;
3,兩天內,累計下跌等于或超過20%選股.
xg:(ref(c,2)-c)/c>0.2;
4,股價是25天以來新低.
xg:c<ref(llv(c,25),1);
5,選股:EXPMA 5日與10日金叉 并且第二天的收盤價在EXPMA的5日線以上.
cross(ref(ema(c,5),1),ref(ema(c,10),1)) and c>ema(c,5);
6,請編買入公式:
1. 將BIAS指標的參數設置為24日,將KD指標的參數設置為9;3;3。
2. BIAS指標要小于-6,這只是確認該股超跌的初選條件。
3. KD指標產生黃金交叉,K線上穿D線。
4. KD交叉同時,KD指標中的D值要小于16。
BIAS3 :=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100,colorff00ff;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1),COLORWHITE;
D:=SMA(K,3,1),COLORYELLOW;
xg:BIAS3<-6 and cross(k,d) and d<16;
7,要求是量大、換手率達到3左右,漲幅>7個點。
xg:v/capital*100>3 and (c/ref(c,1)>1.07;
8,個股分時圖上都有一條黃線,叫做均價線
a/capital*100;
9,"陰轉陽"的公式(也就是昨天收陰線,今天收陽線)
xg:ref(c,1)<ref(o,1) and c>o;
10,股價回抽20日均線選股公式
xg:ref(c,1)>ma(c,20) and cross(ma(c,20),c);
11,一根大陽線,至少有5個點以上,再連著出現二根振幅不大于5的十字星或是小K線
xg:(ref(c,3)-ref(c,4))/ref(c,3)>0.05 and count((h-l)/l<0.05,2)=2;
12,行情信息里的“漲幅”的原碼
(c-ref(c,1))/c*100;
13,kdj的J從上向下穿越O軸發出信號
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1),COLORWHITE;
D:=SMA(K,3,1),COLORYELLOW;
J:=3*K-2*D,COLORFF00FF;
xg:cross(0,j);
14,股價4天中有兩天在10日線上
count(c>ma(c,10),4)=2;
15,選出10天內出現了漲停的個股
count(c/ref(c,1)>1.1,10)>0;
又:
今漲停:=C/REF(C,1)>1.09;
選股:count(今漲停,n);
16,一陽上穿10,20,30日線,量能是前一天3倍。
xg:cross(c,ma(c,10)) and cross(c,ma(c,20)) and cross(c,ma(c,30)) and v>ref(v,1)*3;
17,共三根K線,第一根K線為陰線;第二根K線為陰線線,最高價低于第一根K線,最低價高于第一根K線;第三根K線陰陽不限,最高價低于第二根K線,最低價高于第二根K線。滿足后發出信號~
w1:=ref(c,2)<ref(o,2);
w2:=ref(h,2)>ref(h,1) and ref(l,2)<ref(l,1);
w3:=ref(h,1)>h and ref(l,1)<l;
xg:w1 and w2 and w3;
18, 選出今日成交量大于昨日成交量一成的股票。
xg:v>ref(v,1)*1.1;
19, 連續5天,當日的5日均線減前一天的5日均線差值小于1.
count((ma(c,5)-ref(ma(c,5),1))<1,5)=5;
20,股價上穿5周均線:
xg:cross(c,ma(c,5));
注意:選股時用周線
21,上穿30日均線的公式
xg:cross(c,ma(c,30));
22,兩筆陰線中間夾著一根陽線或數根K線,其中兩筆陰線最低點相等
xg:ref(l,2)=l;
23,量比大于1 同時換手大于2的公式
xg:v/ref(v,1)>1 and AMOUNT/CAPITAL*100>2;
24,換手:VOL*100/CAPITAL;
周期換手:SUM(換手,10);
25,流通盤小于4000萬 的選股公式
xg:CAPITAL/100<4000;
26,漲停開盤跌停收盤選股
xg:h/ref(c,1)>1.1 and ref(c,1)/l>1.1;
27,當天開盤價與收盤價相等的選股公式
xg:c=o;
28,5日均線向上 流通盤小于5000萬 換手率大于3的選股公式
lt:CAPITAL/100<5000;
換手:=VOL*100/CAPITAL<3;
w1:ma(c,5)>ref(ma(c,5),1);
xg:lt and 換手 and w1;
29,收下影線
xg:c>l;
30, o=l就沒有下引線了,那就:
xg:c>l and o>l;
31,當日收盤下穿5日均價
xg:cross(ma(c,5),c);
32,最低價小于前一日的最低價但收盤后為陽線。
xg:l<ref(l,1) and c>o;
33,30日內到本日收盤價下跌20%的公式
xg:hhv(c,30)/c>1.2;
34,選周線跳空缺口的個股。
xg:HIGH<REF(LOW,1) OR
LOW>REF(HIGH,1);
周期選周線
35,30日均線走平或走高的個股
xg:ma(c,30)>ref(ma(c,30),1);
36,連續4天的收盤價格波動幅度在3%之內連續走平或向上
count(abs(c-ref(c,1)/ref(c,1))<0.03 and c>ref(c,1),3)=3;
37,下影線長于上影線
(c-l)>(h-c);
38, 收盤價+收盤價的10%
(c+c*0.1);
39,今天高開的公式
c>o;
40,今天的量大于等于昨天量的2倍,股價上漲
xg:v>ref(v,1)*2 and c>ref(c,1);
41,今天的量小于昨天量的2倍以上,股價上漲
xg:v<ref(v,1)*2 and c>ref(c,1);
42,大部分股票跌到43日均線時就會反彈,如果在43日均線附近買入,短線成功率占90%以上,即時選出還差幾分錢就跌到43日均線的股票。
xg:abs(c-ma(c,43))/ma(c,43)<0.01;
43,{選出每天換手5%-15%之間的股票}
Var1:=100*VOL/CAPITAL;
w1:=var1>5;
w2:=var1<15;
xg:w1 and w2;
44,換手率10天80%以上的選股公式
sum(VOL/CAPITAL*100,10)>80;
45,60個交易日內,漲幅大于9.9%(漲停)的天數
count(c/ref(c,1)>1.099,60);
46,昨天跌幅大于3%,今天開盤高開2%以上的選股公式。
xg:ref(c,1)/ref(c,2)<0.97 and o/ref(c,1)>1.02;
47,選出周換手率小于10%的股票
sum(VOL/CAPITAL*100,5)<10;
48,成交量創20日新低,并且股價也創20日新低
xg:v=llv(v,20) and c=llv(c,20);
49,5日不漲,綠線收盤選票指標
count(c<o,5)=5;
50,"今日MACD等于昨天的MACD ,且macd>0" 的指標
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
xg:macd=ref(macd,1) and macd>0
51,連續2天收盤價跌破30日均線,就顯示”賣出”信號
a1:count(c<ma(c,30),2)=2;
drawtext(a1,c,'賣出'),colorgreen;
52,股票在這條均線上在8天以上,上下幅度不大,
a1:abs((c-ma(c,120))/ma(c,120))<0.1;
xg:count(a1,8)=8;
53, 連續三天高開高走的選股公式
count(o>ref(c,1) and c>o,3)=3;
54,n天內曾經有m個漲停
count(c/ref(c,1)>1.09,n)>m;
55,股價比昨天的高,量比昨天小,放量。
xg:c>ref(c,1) and v<ref(v,1) and ref(v,1)>ref(v,2)*2;
56,連續3天每天的最低價都比前一天高
count(l>ref(c,1),3)=3;
57,周量縮小50%或40%或n%
a1:vol/capital*100;
xg:a1/ref(a1,1)<n/100;
58,股價超過五日均價的15%以上,并給出賣出信號
賣出:c/ma(c,5)>1.15;
59,連收兩個十字星的選股公式
count(abs((c-o)/o<0.01),2)=2;
60,n橫盤天數,n1橫盤的上下幅度
REF(((HHV(H,N)-LLV(L,N))/LLV(L,N)),1)<=(n1/100)
and ref(v,1)<ref(ma(v,5),1) and cross(v,ma(v,5)) and cross(v,ma(v,10));
61,收盤價連續8天都站在5日均線的股票。
count(c>ma(c,5),8)=8;
62,振幅大于5%,收盤價大于3.5小于15元,三日均線大于昨日的三日均線,去掉ST股。
a1:=h/l>1.05;
a2:=c>3.5 and c<15;
a3:=ma(c,3)>ref(ma(c,3),1);
xg:a1 and a2 and a3;
63,收盤價下有60天前的遠期獲利盤n%。
{60天前的遠期獲利盤:=ppart(60)*100;}
aa:WINNER(ref(c,60 ))*100;
64,連續三日收陽 后日收盤高于前日 且每日收于當日最高價附近 每日漲幅不大于4%
選股:count(c>o and c>ref(c,1) and abs((h-c)/c)<0.01 and c/ref(c,1)<1.04,3)=3;
65,昨日收陰, 今日收陽,的K線組合。
C>O AND REF(C,1)<REF(O,1);
66,股價突破5ma買入,跌破5ma賣出。買入和賣出用箭頭表示 (副圖)
a1:cross(c,ma(c,5));
a2:cross(ma(c,5),c);
drawtext(a1,low*0.98,'↑'),colorred;
drawtext(a2,h*1.02,'↑'),color00ffff;
67,今天的250平均線大于昨天的昨天的250平均線
ma(c,250)>ref(ma(c,250),1);
68,歷史高點到前一高點畫線
POLYLINE(h>=hhv(c,0),h);
69,均線中增加一根線,這根線的價格是5日線的1.2倍
aa:ma(c,5)*1.2;
70,20天均線向上的股
xg:ma(c,20)>ref(ma(c,20),1);
71,連續3天收盤全是陰線。
count(c<ref(c,1),3)=3;
72,今天收盤價在昨天收盤價-2%~2%之間
c/ref(c,1)>0.98 and c/ref(c,1)<1.02;
73,收盤價在5日均線以上5天
count(c>ma(c,5),5)=5;
74,N天前換手率大于8%
REF(VOL/CAPITAL*100,N)>8;
75,一條均線18MA 股價上漲后“縮量”回調到18MA
XG:COUNT(V<REF(V,1) AND C<O,N)=N AND C>MA(C,18);
N “縮量”回調的天數
76,1。昨日量是n天以來最低量,(n可調);2。今日量是昨日量的m倍,(m可調);3。今日k線收陽線;
xg:ref(v,1)=llv(ref(v,1),n) and v>ref(v,1)*m and c>o;
77,第一天收陰,第二天,第三天,第四天,收出紅三兵
XG:REF(C,3)<REF(C,4) AND COUNT(C>O,3)=3;
78,月k線十字星收盤 并且5月線拐點向上。
XG:ABS(C-O)/O<0.02 AND MA(C,5)>REF(MA(C,5),1);
用月線選股
79,最近3天(包括昨天.前天)股價突破250日均線
COUNT(C>MA(C,250),3)=3;
80,跳高大陰線,條件: 1 開盤跳空4%以上2 大陰線實體6%以上.
O/REF(C,1)>1.04 AND C/REF(C,1)<0.94;
81,條件:1: 假設大前天創最近新高,要求這天漲幅是超過7%的大陽線,且創最近一個月的新高.
2: 那么前天,昨天,今天都收小K線,要求小K線實體
xg:ref(c,3)/ref(c,4)>1.07 and ref(c,3)=hhv(c,20) and count(abs((c-ref(c,1))/ref(c,1)<0.02,3)))=3;
82,60與120均線距離在n%內
XG:ABS((MA(C,60)-MA(C,120))/MA(C,120))<N/100;
83,5日均線傾角大于60度
X:(ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.14115926)>60;
也可以這樣:
X:(ATAN((EMA(C,5)/REF(EMA(C,5),1)-1)*100)*180/3.14115926)>60;利用指標排序:X:(ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.14115926);
84,“中陰之后,跳拉陽”c/ref(c,1)>1.05;
------------------------------------------------------------------------------------------------------
85,count(x,n) 意思是n天內出現過信號的,假設n=10,那么就是10天內出現信號(包括今天),如果不加這個的話,就是限定在今天出信號才選出來,以前的不管。
86, 今天漲停的公式C/REF(C,1)>1.09;
87,10日內有漲停的公式今漲停:=C/REF(C,1)>1.09;
選股:count(今漲停,10);
88,昨日前日漲停的REF(C,1)/REF(C,2)>1.095;
--------------------------------------------------------------------------------------------------------
89,近5日K線最高價和最低價格波動在10%以內,成交量是昨日2倍,收盤漲5%
XG:(HHV(C,5)-LLV(C,5))/LLV(C,5)<0.1 AND V>REF(V,1)*2 AND C/REF(C,1)>1.05;
90,60與120均線距離在n%內XG:ABS((MA(C,60)-MA(C,120))/MA(C,120))<N/100;
91,“中陰之后,跳拉陽”c/ref(c,1)>1.05;
92,能在圖上提示個股(不含S或ST股)出現過的漲跌停板日期的公式
w1:if((c-ref(c,1))/ref(c,1)>0.1,date-1000000,c);
93,漲幅≤2%(c-ref(c,1)/ref(c,1)*100<2;
94,5日,10日,30日貼近公式,越貼越好m1:=ma(close,5);
m2:=ma(close,10);
m3:=ma(close,20);
m4:=ma(close,30);
y1:=max(max(max(m1,m2),m3),m4);
x1:=min(min(min(m1,m2),m3),m4);
黏合:y1/x1<n;
n越小越黏合(n,1.01-----1.05)
95,(1)換手率均線DMA(c ,v/CAPITAL );
(2)20天以來的任意天期(n),換手率均線正負波動值<=p%;
AA:=DMA(c ,v/CAPITAL );
ab:=(aa-ref(aa,1))/ref(aa,1)*100<p;
bb:count(ab,20)>=n;
96, 30天線拐頭向上出現提示
ma(c,30)>ref(ma(c,30),1);
97,今天的換手率大于前天的一倍以上
w1:=v*100/capital;
w1>ref(w1,2)*2;
98,K線沿著5日均線往上爬的選股公式 w1:ma(c,5);
w2:abc(c-w1)/w1<0.01;
xg:count(w1>ref(w1,1),5)=5 and w2;
99,20日均線,上穿62日均線 xg:cross(ma(c,20),ma(c,62));
100,平臺整理的公式,整理時間和整理幅度可調
COUNT(CLOSE,0)>N AND
(HHV(CLOSE,N)-LLV(CLOSE,N))/LLV(CLOSE,N)<=(N1/100);
N整理時間,N1整理幅度
101,選出當日收盤價突破10日均線5%的個股
cross(c,ma(c,10)*1.05);
102,選出當日最低價在10日均線上下0.05%內,收盤價在均線上方的個股
abs(l-ma(c,10))<0.005 and c>ma(c,10);
103,第一天股票漲停,第二天成交量是第一天成交量的1倍,并超過10%.那第三天就是買點
w1:=ref(c,2)/ref(c,3)>1.1;
w2:=ref(v,1)/ref(v,2)>2;
xg:w1 and w2;
104,放量2倍突破300日線的選股指標
cross(c,ma(c,300)) and v>ref(v,1)*2;
105,3日均線上穿10日均線,KDJ有效金叉
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
w1:=cross(ma(c,3),ma(c,10));
xg:w1 and cross(k,d);
106,30日均線拐頭向上ma(c,30)>ref(ma(c,30),1);
107,連續3-5天,每天的收盤價漲跌幅不超過1%.w1:abs(c-o)<0.01;
xg:count(w1,5)>=3;
108,K線收十字星abs(c-o)/o<0.01;
109,MACD在8天以內兩次金叉DIFF:=(EMA(CLOSE,12) - EMA(CLOSE,26));
DEA:=EMA(DIFF,9),COLORBLUE,LINETHICK0;
MACD:=2*(DIFF-DEA);
w1:cross(DIFF,dea);
xg:count(w1,8)>=2;
110,昨天升降幅在-n%----n%之間
w1:abs(ref(c,1)-ref(c,2))/ref(c,2)*100<n;
111,于20日均線相差2個百分點的
w1:abs(c-ma(c,20)/ma(c,20)*100<2;
N日均線相差M個百分點的公式.
w1:abs(c-ma(c,n)/ma(c,n)*100<m;
n:N日 m:M個百分點
112,60MA由向下調頭向上ma(c,60)>ref(ma(c,60),1);
113, 股價回調到14日均線的選股 abs(c-ma(c,14))/ma(c,14)<0.005;
114,歷史第5根K線到第30根K線之間的最高價hhv(ref(c,5),25);
115,MACD的拐點公式DIFF:=(EMA(CLOSE,12) - EMA(CLOSE,26));
DEA:=EMA(DIFF,9),COLORBLUE,LINETHICK0;
MACD:=2*(DIFF-DEA);
拐點:ref(macd,2)>ref(macd,1) and ref(macd,1)<macd;
116,跳空高開收陽線LOW>REF(HIGH,1) and c>o;
117,漲停過300日線的選股公式
c/ref(c,1)>1.09 and cross(c,ma(c,300));
118,成交量是前5天中其他任何一天的10天均量線的3.5倍以上
w1:=llv(ma(v,10),5);
xg:v>w1*3.5;
119,股價N天內連續沿著5天線走,且每天收盤價與5天線的距離不超過2%的選股公式
w1:=abs(c-ma(c,5))/ma(c,5)<0.02;
xg:count(w1,n)=n;
120,跳空高開后,三天內沒有回補缺口
ref(LOW,2)>REF(HIGH,3) and l>ref(LOW,2);121,日漲幅小于3%C>0 AND C/REF(C,1) >1.03;
122, 股價創30個交易日的新高H>ref(H,30);
123,連續n天收陽線UP:=CLOSE>OPEN;
COUNT(UP,N)=N;
124, {5日內第二大量}
zdl:=hhv(v,5);
v0:=IF(v>=zdl,0,v);
v1:=IF(ref(v,1)>=zdl,0,ref(v,1));
v2:=IF(ref(v,2)>=zdl,0,ref(v,2));
v3:=IF(ref(v,3)>=zdl,0,ref(v,3));
v4:=IF(ref(v,4)>=zdl,0,ref(v,4));
第二大量:MAX(MAX(MAX(MAX(v0,v1),v2),v3),v4);
DRAWTEXTABS( 0,10 ,'第一大量 '+ zdl+' 第二大量'+第二大量);同理可求出第三大、第四大和最小量.實行簡單的排列.
這個公式好比是一件完整產品中的一個零部件,解決了一個思路問題.
125,{5日均線傾角大于60度}
X:(ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.14115926)>60;

請高手把這個指標改成選股公式(多謝)

可以編寫指標選股公式妖股起漲,選股位置提示效果如下圖

請老師幫忙把(買入漲停指標)做成選股公式

散戶的三個喜歡:
1、喜歡預測大盤
癡迷于預測大盤是散戶炒股為什么會賠錢的重點原因,除了極少數情況下次日大盤必漲外,短線大盤的走勢其實是不可預測的。這也就說,平日里散戶關注的機構測市等節目并沒有多大意義。對于看大盤做個股的朋友來說,可以把大盤分為可操作段與不可操作段更有意義,至于具體區分方法有很多,比如說30日均線,MACD,或者是一些更敏感的指標。
2、喜歡抄底
尤其是處于歷史低位的股票,是散戶炒股為什么會賠錢的關鍵原因??吹阶约旱某杀颈葎e人都低,心里簡直是樂開了花。卻沒有想到,一個股票既然已創出了歷史新低,那么很可能還會有很多新低出現,甚至用不了幾個月股票就被腰斬了。
3、喜歡短線
只要是股民,心中都有幾個牛股,有的漲了300%,有的漲了500%,甚至漲了1000%!但是你可以看看,除去特力A等幾只妖股,有幾只是十天半個月可以實現的!哪一個牛股不是經歷了至少3個月以上的時間才有這樣的漲幅?
股市中有句俗話:成交量無法騙人,這句話有一定的道理。主力在吸籌、拉高、出貨等階段,可以用各種技術指標蒙騙股民,但千騙萬騙,成交量是無法騙人的。因為股票要漲,必須有主動性的買盤積極介入,即買的人多了,股價自然上漲;反之,大家都爭先恐后地、不惜成本地賣,股價就會下跌,這在成交量上能反映得比較清楚。

通達信捉妖神器主圖及選股指標公式怎么用

你的問題只能找原公式編寫者,除非,你能提供此公式源碼,才能幫你。

做超短股如何選股?

除了MACD和KDJ外,另外常用的指標還有RSI,BIAS,DMI.其中DMI較復雜,估計用軟件的話這個指標不好用.
RSI相對強弱指數值在0~100之間波動。一般相對強弱指數的變化范圍在30~70之件,其中又以40~60之件的機會較多,超過80或低于20的機會很少。
當股市經過一段下跌行情,相對強弱指數也隨之從高位持續跌至30以下,如果由低位向上突破60并或確認,則表明多頭力量重新占據上鋒。
當股市經過一段上漲行情,相對強弱指數也隨之從低位漲至80以上后,如果從高位向下跌破40,則表明空頭力量重新占據上鋒。
在高價區與低價區內相對強弱指數的變動與股價變化不一致時說明大勢即將反轉。
相對強弱指數圖形中曾經出現的最高點具有較強的反壓作用;相對強弱指數曾經出現的最低點具有較強的支撐作用。
多頭市場中如果有價格回檔,多頭的第一道防線是RSI=50,第二道防線是RSI=40,第三道防線是RSI=30。
空頭市場中如果有價格反彈,空頭的第一道防線是RSI=50,第二道防線是RSI=60,第三道防線是RSI=70。
多頭市場中RSI值每次因股價回檔下跌而形成的低點密集區也是多頭的第一道防線??疹^市場中股價處于反彈盤整階段RSI所出現的高點也是空頭的一道防線。
盤整階段的值在40~60之間,如果市場走強,RSI值往往可以在80以上。反之,股票市場交易不景氣時RSI值在20以下。
BIAS:乖離率。股價與移動平均線的偏離程度。
股價在移動平均線上方叫上乖離,乖離率為正值,距離越遠則乖離程度越大,同時移動平均線對股價有引力作用,將越可能
發生向移動平均線回歸的過程,引起下跌;股價在移動平均線下方叫下乖離,乖離率為負值,距離越遠則乖離程度越大,同時
移動平均線對股價有回拉作用,將越可能發生向移動平均線回歸的過程,引起股價上漲。至于BIAS值達到何種程度才是買進
或賣出時機并沒有統一的法則,有人以10日、25日均線的BIAS值-4.5~7%或5~8%為買進或賣出時機。
W%R:威廉指標。是一個短線指標,描述超買、超賣的極端狀態時較模糊,W%R在0~20之間變化時只表示市場處于較強的上升趨
勢中。
DMI:動向指標。(參考)
1、 黃金交叉與死亡交叉,當-DI向上突破+DI時是黃金交叉,是買入時機,當+DI向下突破-DI時是死亡交叉,是賣出時機。
2、 當ADX和+DI一起漲時是多頭市場,當ADX和-DI一起漲時是空頭市場。
3、 ADX從高處下落時是轉勢,轉折強烈時亦可考慮賣出或買入。
DIF、MACD> 0:多頭市場;DIF、MACD< 0:空頭市場;KD<20:買;KD> 80:賣;0< RSI<50:弱;50< RSI<100:強;
RSI> 80:超買區;RSI<20:超賣區;BIAS:-4.5~7%或5~8%;W%R在0~20之間變化時只表示市場處于較強的上升趨勢中。
MACD指標的一般研判標準
MACD指標是市場上絕大多數投資者熟知的分析工具,但在具體運用時,投資者可能會覺得MACD指標的運用的準確性、實效性、可操作性上有很多茫然的地方,有時會發現用從書上學來的MACD指標的分析方法和技巧去研判股票走勢,所得出的結論往往和實際走勢存在著特別大的差異,甚至會得出相反的結果。這其中的主要原因是市場上絕大多數論述股市技術分析的書中關于MACD的論述只局限在表面的層次,只介紹MACD的一般分析原理和方法,而對MACD分析指標的一些特定的內涵和分析技巧的介紹鮮有涉及。本節將在介紹MACD指標的一般研判技巧和分析方法基礎上,詳細闡述MACD的特殊研判原理和功能。
MACD指標的一般研判標準主要是圍繞快速和慢速兩條均線及紅、綠柱線狀況和它們的形態展開。一般分析方法主要包括DIF和MACD值及它們所處的位置、DIF和MACD的交叉情況、紅柱狀的收縮情況和MACD圖形的形態這四個大的方面分析。
一、DIF和MACD的值及線的位置
1、當DIF和MACD均大于0(即在圖形上表示為它們處于零線以上)并向上移動時,一般表示為股市處于多頭行情中,可以買入或持股;
2、當DIF和MACD均小于0(即在圖形上表示為它們處于零線以下)并向下移動時,一般表示為股市處于空頭行情中,可以賣出股票或觀望。
3、當DIF和MACD均大于0(即在圖形上表示為它們處于零線以上)但都向下移動時,一般表示為股票行情處于退潮階段,股票將下跌,可以賣出股票和觀望;
4、當DIF和MACD均小于0時(即在圖形上表示為它們處于零線以下)但向上移動時,一般表示為行情即將啟動,股票將上漲,可以買進股票或持股待漲。
二、DIF和MACD的交叉情況
1、當DIF與MACD都在零線以上,而DIF向上突破MACD時,表明股市處于一種強勢之中,股價將再次上漲,可以加碼買進股票或持股待漲,這就是MACD指標“黃金交叉”的一種形式。
2、當DIF和MACD都在零線以下,而DIF向上突破MACD時,表明股市即將轉強,股價跌勢已盡將止跌朝上,可以開始買進股票或持股,這是MACD指標“黃金交叉”的另一種形式。
3、當DIF與MACD都在零線以上,而DIF卻向下突破MACD時,表明股市即將由強勢轉為弱勢,股價將大跌,這時應賣出大部分股票而不能買股票,這就是MACD指標的“死亡交叉”的一種形式。
4、當DIF和MACD都在零線以上,而DIF向下突破MACD時,表明股市將再次進入極度弱市中,股價還將下跌,可以再賣出股票或觀望,這是MACD指標“死亡交叉”的另一種形式。
三、MACD指標中的柱狀圖分析
在股市電腦分析軟件中(如錢龍軟件)通常采用DIF值減DEA(即MACD、DEM)值而繪制成柱狀圖,用紅柱狀和綠柱狀表示,紅柱表示正值,綠柱表示負值。用紅綠柱狀來分析行情,既直觀明了又實用可靠。
1、當紅柱狀持續放大時,表明股市處于牛市行情中,股價將繼續上漲,這時應持股待漲或短線買入股票,直到紅柱無法再放大時才考慮賣出。
2、當綠柱狀持續放大時,表明股市處于熊市行情之中,股價將繼續下跌,這時應持幣觀望或賣出股票,直到綠柱開始縮小時才可以考慮少量買入股票。
3、當紅柱狀開始縮小時,表明股市牛市即將結束(或要進入調整期),股價將大幅下跌,這時應賣出大部分股票而不能買入股票。
4、當綠柱狀開始收縮時,表明股市的大跌行情即將結束,股價將止跌向上(或進入盤整),這時可以少量進行長期戰略建倉而不要輕易賣出股票。
5、當紅柱開始消失、綠柱開始放出時,這是股市轉市信號之一,表明股市的上漲行情(或高位盤整行情)即將結束,股價將開始加速下跌,這時應開始賣出大部分股票而不能買入股票。
6、當綠柱開始消失、紅柱開始放出時,這也是股市轉市信號之一,表明股市的下跌行情(或低位盤整)已經結束,股價將開始加速上升,這時應開始加碼買入股票或持股待漲。
KDJ指標的中文名稱是隨機指數,最早起源于市場。
KDJ指標的應用法則KDJ指標是三條曲線,在應用時主要從五個方面進行考慮:KD的取值的絕對數字;KD曲線的形態;KD指標的交叉;KD指標的背離;J指標的取值大小。
第一,從KD的取值方面考慮。KD的取值范圍都是0~100,將其劃分為幾個區域:80以上為超買區,20以下為超賣區,其余為徘徊區。
根據這種劃分,KD超過80就應該考慮賣出了,低于20就應該考慮買入了。應該說明的是,上述劃分只是一個應用KD指標的初步過程,僅僅是信號,完全按這種方法進行操作很容易招致損失。
第二,從KD指標曲線的形態方面考慮。當KD指標在較高或較低的位置形成了頭肩形和多重頂(底)時,是采取行動的信號。注意,這些形態一定要在較高位置或較低位置出現,位置越高或越低,結論越可靠。
第三,從KD指標的交叉方面考慮。K與D的關系就如同股價與MA的關系一樣,也有死亡交叉和黃金交叉的問題,不過這里交叉的應用是很復雜的,還附帶很多其他條件。
以K從下向上與D交叉為例:K上穿D是金叉,為買入信號。但是出現了金叉是否應該買入,還要看別的條件。第一個條件是金叉的位置應該比較低,是在超賣區的位置,越低越好。
第二個條件是與D相交的次數。有時在低位,K、D要來回交叉好幾次。交叉的次數以2次為最少,越多越好。
第三個條件是交叉點相對于KD線低點的位置,這就是常說的“右側相交”原則。K是在D已經抬頭向上時才同D相交,比D還在下降時與之相交要可靠得多。
第四,從KD指標的背離方面考慮。在KD處在高位或低位,如果出現與股價走向的背離,則是采取行動的信號。
第五,J指標取值超過100和低于0,都屬于價格的非正常區域,大于100為超買,小0為超賣。

  • 1.003853基金查詢天天
  • 2.etf基金傭金不留
  • 3.請問易基50基金凈值是多少
  • 4.多牛金融
  • 5.可轉債中簽時間段大數據
  • 6.怎么計算價格指數
  • 7.原股東配債什么意思
  • 8.個股所屬板塊至少有一個漲停公式
  • 国产亚洲AV手机在线观看